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Контрольные задания
по курсу “Интегрированные системы 
проектирования и управления ”

для студентов заочной формы обучения

 специальности 220700 Автоматизация технологических процессов и производств 

Изучение курса “Интегрированные системы 
проектирования и управления ”  включает: 

а) работу над учебными пособиями;

б) выполнение контрольных работ;

в) посещение лекций и консультации по отдельным разделам курса;

г) выполнение лабораторных работ;

д) решение практических задач.

По основным вопросам и наиболее сложным темам курса, которые вызывают затруднения при самостоятельном изучении, студентам читаются лекции.

После изучения очередной темы курса студент должен уметь ответить на вопросы для самопроверки.

Контрольная работа включает в себя два задания. Одно практическое, одно теоретическое. Вариант задания определяется по последней цифре зачетной книжки студента.

После выполнения контрольной работы студент допускается к выполнению лабораторных работ, а после их выполнения – к сдаче экзамена.
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Задание №1

«Создание программы на языке FBD»
Запустите Concept. Создайте новый проект File → New project. Выполните конфигурирование контроллера. Закройте окно PLC Configuration. Создайте новую секцию File → New section…, выберите язык FBD и введите имя секции (до 32 символов), которое должно быть уникальным для всего проекта и должно удовлетворять соглашениям стандарта IЕС 61131-3 по име​ни, в противном случае появится сообщение об ошибках. Согласно стандарту, только буквы позволяются как первый символ имени секции. В результате описанных выше действий появится поле для размещения блоков из 23 строк и 30 столбцов.
В редакторе FBD на фоне плоскости окна видна некоторая ло​гическая сетка. В процессе конфигурирования каждый FFB раз​мещается в ячейках этой сетки. Если FFB помещаются вне ячейки сетки или в случае перекрытия их с другими FFB, то появляется сообщение об ошибке и FFB не будет размещен в этой ячейке. Внешние параметры, задаваемые в явном виде на входах/выходах FFB, могут пересекаться другим объектом, но не должны нару​шать границы ячеек сетки.
Чтобы вставить FFB в секцию, достаточно набрать команду меню Objects → FFB selection... Диалоговое окно FFBs from Library будет открыто. С помощью командной кнопки Library... в этом диалоговом окне осуществляется выбор библиотеки, из кото​рой будут выбираться FFB. Для отображения уже созданных DFB, чтобы выбрать один из них, используется командная кнопка DFB. Теперь поместите выбранный FFB в секцию.
Если линия связи, обеспечивающая соединение с другим FFB, зафиксирована, то это соединение будет контролироваться редак​тором FBD. Если же подобное соединение запрещено, то будет выдано сообщение о его запрещении и линия связи не будет сге​нерирована. В процессе формирования связей между FFB допус​каются перекрытия и перекрещивания с другими связями и FFB.
Базируясь на логике программы, входу/выходу FFB с помощью редактора переменных можно назначить: переменную, константу, литерал, прямой адрес. Окно, изображенное на рисунке 1 выводится по двойному щелчку левой кнопки мыши на входе FFB. 
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Рисунок 1 – Редактор переменных
Нелокализованная переменная, назначаемая входу/выходу, может использоваться как маркер, то есть для создания контуров или для передачи значений между различными секциями.
С помощью локализованной переменной, связанной с конкрет​ным адресом, входу/выходу может быть назначен сигнал вво​да/вывода аппаратного обеспечения.
Константа может быть помещена в другие секции.
Чтобы просмотреть список всех объявленных переменных или входов/выходов и сделать выбор из этого списка, используйте ко​мандную кнопку Lookup.
Если переменная не была объявлена, используйте команду Project → Variable declarations... или командную кнопку [image: image2.png]


, или кнопку F8 – функциональной части клавиатуры, для того, чтобы вызывать диалоговое окно Variable Editor для объявления нелокализованных переменных, констант, вход​ных или выходных параметров. В этом окне можно объявить имя, тип данных, начальное значение и/или комментарий для нелокали​зованных переменных. Для констант объявляется имя, тип данных, значение и, в случае необходимости, комментарий.
Текстовые объекты не могут перекрываться с FFB, но могут пе​рекрываться с линиями связи. Текстовые объекты не занимают па​мять в ПЛК, потому что они, как правило, не загружаются в ПЛК.
Сохраните FBD-секцию с помощью команды меню File → Save project.
Пример 1. Создание программы на языке FBD. 

Составим программу на языке FBD, реализующую систему управления перемещением горизонтального крана.

Имеется три дискретных входа системы управления («кнопки без памяти»):

ON_LE – начать перемещение влево;

ON_RI – начать перемещение вправо;

STOP – остановить движение.

Имеется два выхода для исполнительных механизмов:

MOT_LE – перемещение крана влево;

MOT_RI – перемещение крана вправо.

Двигаясь в одном направлении, кран не воспринимает команду изменения направления перемещения. Чтобы изменить направление перемещения, кран необходимо остановить. 

Одновременная подача единичных изменений на выходы не допускается.

На рисунке 3 представлено решение этой задачи на языке FBD (файл KRANFBD1.PRJ). На рисунке 4 представлено окно редактора переменных согласно условиям задачи.
Описание блока RS из группы Bistable библиотеки IEC. Блок RS работает по принципу RS-триггера. Пример применения блока RS смотрите в части I методических указаний к лабораторным работам. 
Общий вид блока представлен на рисунке 2. 
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Рисунок 2 – Общий вид блока RS
Описание параметров блока:

Параметр

Тип данных
Назначение
S


BOOL

Установка
R1

BOOL

Доминирующий сброс
Q1

BOOL

Выход
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Рисунок 3 – Решение на языке FBD
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Рисунок 4 – Окно редактора переменных

Задание 1.

Создать программу на языке FBD согласно условиям задачи примера 1, изменив условия задачи следующим образом:

1) Время перемещения в каждом направлении нужно контролировать. Перемещение влево должно прекращаться через Х с, а перемещение вправо – через Y с.

2) Направление перемещения изменяется автоматически по истечении указанного времени.

Рекомендации: используйте стандартный блок TON из библиотеки Timer.

Описание блока TON. Таймер. Общий вид блока приведен на рисунке 5.
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Рисунок 5 – Общий вид блока TON
Описание параметров блока

Параметр
Тип данных

Назначение

IN

BOOL


Начало задержки

PT

TIME


Установка времени 

задержки

Q

BOOL


Выход

ET

TIME


Внутреннее время
Решение представлено на рисунке 6. На рисунке 7 представлено окно редактора переменных.
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Рисунок 6 – Решение на языке FBD

[image: image8.png]variable Editor

=10l

[T Search/Paste
& Vaiables (" Constaris e
Ep Variable Name Data Type Addess Iritvalue Use2]

1 0 etle INT 400001 1 J
e W ooo: F
T e ]
AT e =
50 8 ok JBo0L oo | I
510 & i JBo0L oo | i
7 | = s [s00L oz | 2
e e ]
A e ]
= -
R = [

Lt o

z = =




Рисунок 7 – Окно редактора переменных
Задание №2
«Создание программы на языке LD»
Запустите Concept. Создайте новый проект File → New project. Выполните конфигурирование контроллера. Закройте окно PLC Configuration. Для создания программы на языке LD необходимо создать новую LD-секцию и ввести имя секции. Появится информационное поле для размещения элементов языка LD на 230 строк и 52 столбца.
Имя секции (до 32 символов) должно быть уникальным для всего проекта и должно удовлетворять соглашениям стандарта по имени, в противном случае появится сообщение об ошибках. Если введенное имя секции уже существует, Вы будете предупреждены, и  должны выбрать другое имя.
В LD-редакторе фон окна является логической сеткой, которая показывает так называемую левую шину питания на левой сторо​не. Эта левая шина питания соответствует фазе (L-шина) ступени.
Как и в ступени, только те объекты LD (контакты, катушки), кото​рые соединены с источником питания, т. е. подключены к левой шине питания, будут обработаны во время программирова​ния секции LD.  Правая шина питания, которая соответствует нейтральному проводнику, оптически не отображается. Но внут​ренне все катушки и выходы FFB подключены к ней, что обеспе​чивает протекание тока.
Чтобы вставить контакт или катушку в секцию, нужно открыть главное меню Objects и выбрать желаемые контакт или катушку. Контакты и катушки могут также быть выбраны в инструменталь​ной панели.
Поместите контакты или катушки в секцию.
Чтобы вставить FFB в секцию, выберите команду меню Objects → FFB Selection... . Диалоговое окно FFBs from Library будет открыто. Используйте командную кнопку Library... в этом диалоговом окне, чтобы найти библиотеку, из которой можно выбрать FFB. Вы можете также использовать командную кнопку <DFB> для отображения созданных блоков DFB, чтобы выбрать один из них. Теперь поместите выбранный FFB в секцию.
Во время размещения объекты выравниваются в растре сетки. При размещении объектов снаружи фрейма секции или при перекрывании другим объектом появится сообщение об ошибках, и объект не будет размещен. При размещении контактов и катушек они автома​тически связываются со смежными, несвязанными контактами и ка​тушками, если контакт или катуш​ка находится на той же самой вертикали. Связь с шиной питания бу​дет установлена, только если контакт помещен поблизости. Если ка​тушка или контакт помещены в уже существующую горизонтальную связь, то она автоматически будет разорвана и контакт или катушка вставлены. Если размещаются фактические параметры, они могут накладываться на другой объект, но не так, чтобы нарушить границу фрейма секции. Если связь служит как соединение с другим объек​том, это соединение будет проверено. Если соединение не разрешено, то появится сообщение, и связь не будет сгенерирована.
После того как все блоки FFB будут размещены, закройте диа​логовое окно.
Используйте команду Objects → Select, чтобы активи​зировать режим Mode и перемещать контакты, катушки и блок FFB к выбранной позиции.
Используйте команду Objects → Link, чтобы активизировать режим соединения и установить соединения между контактами, катушками и блоками FFB. Установите соединение между контактами, блоками FFB и левой шиной питания.
При создании связей разрешаются перекрытия другими связя​ми и объектами и пересечения с ними. Если выбран блок FFB, его комментарий будет отображаться в первом столбце строки стату​са. Если выбран фактический параметр, его имя (если оно есть), его прямой адрес и его комментарий будут отображаться в первом столбце строки статуса.
Несвязанные контакты, катушки и входы/выходы FFB имеют по умолчанию значение 0.
В дополнение к объектам, рассмотренным выше, текст также может быть помещен в LD-секцию. Размер этого текстового объ​екта зависит от длины текста. В зависимости от размера текста размер объекта может быть расширен на большее количество мо​дулей сетки в вертикальном, а также в горизонтальном направле​нии. Текстовым объектам не разрешено накладываться на другие объекты, хотя они могут накладываться на связи.
Текстовые объекты не занимают место в ПЛК, потому что текст, как правило, не загружается в ПЛК.
Теперь используйте команду Objects → Select, чтобы повторно активизировать режим выбора, и дважды щелкните мышкой по контакту или катушке. Откроется диалоговое окно Properties: LD object, в котором контакту или катушке может быть назначен фактический параметр.
В зависимости от логики программы контакту или катушке и входам/выходам FFB могут быть назначены:
· переменная (локализованная или нелокализованная);
· константа;
· литерал;
· прямой адрес.

Сохраните LD-секцию с помощью команды меню File → Save project.
Пример 2. Создания программы на языке LD. 

По условиям примера 1 требуется создать программу на языке LD.

На рисунке 8 представлено решение этой задачи на языке LD (файл KRAN_LD1.PRJ). На рисунке 9 представлено окно редактора данных согласно условиям задачи.
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Рисунок 8 – Решение на языке LD
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Рисунок 9 – Окно редактора переменных

Задание 2. 

Создать программу на языке LD согласно условиям задания 1.

Решение представлено на рисунке 10. На рисунке 11 представлено окно редактора переменных.
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Рисунок 10 – Решение на языке LD
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Рисунок 11 – Окно редактора переменных
Задание №3
«Создание программы на языке SFC»
Запустите Concept. Создайте новый проект File → New project. Выполните конфигурирование контроллера. Закройте окно PLC Configuration. Создайте новую секцию File → New section…, выберите язык SFC и введите имя секции (до 32 символов), которое должно быть уникальным для всего проекта и должно удовлетворять соглашениям стандарта IЕС 61131-3 по имени, в противном случае появится сообщение об ошибках. Согласно стандарту, только буквы допускается использовать как первый символ имени секции. 
Фон окна в редакторе SFC – это логическая сетка на 200 строк и 32 столбца. Теоретически объекты SFC могут быть помещены в любую свободную ячейку. Если при этом создается связь с объектом (явно или размещением объекта в соседней ячейке),  она будет проверена. При несанкционированном соединении появится сообщение об ошибке.

Вставка объектов. Объекты SFC (шаг, переход и т.д.) могут быть вставлены по отдельности или как группа согласно размеру секции с помощью команд главного меню Objects (последовательность шагов и переходов, структурированная параллельная последовательность и т.д.). То же самое можно сделать с помощью командных кнопок на панели инструментов.
Для выбора Объектов имеется несколько вариантов.

Для выбора одного объекта: 

1) перейдите к режиму выбора;

2) позиционируйте указатель мыши на объект, который будет выбран, и щелкните левой кнопки мыши.

Для выбора нескольких объектов используется клавиша SHIFT. 

Для вызова реквизитов шага сделайте двойной щелчок на шаге или выберите шаг и вызовите команду меню Objects → Properties, чтобы открыть диалоговое окно Step Properties (рисунок 12). В появившемся окне необходимо назначить действие шагу, если требуется – указать спецификатор, время задержки шага. Добавить новые определения к списку действий как новое действие с помощью командной кнопки New Action.
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Рисунок 12 – Окно реквизитов шага
Для вызова реквизитов перехода сделайте двойной щелчок на переходе или выберите переход и вызовите команду меню Objects → Properties, чтобы открыть диалоговое окно Transition Properties. 
Для вызова реквизитов прыжков сделайте двойной щелчок на прыжке или выберите переход и вызовите команду меню Objects → Properties, чтобы открыть диалоговое окно Jump Properties. 

Объявите переменные и их начальные значения в редакторе переменных Project → Variable Editor... 

Создайте логику программы.

Сохраните SFC-секцию с помощью команды меню File → Save project.
Пример 3. Программирование на языке SFC.

По условиям задачи примера 1 требуется создать программу на языке SFC.

Возможное решение задачи представлено на рисунке 13 (файл KRANSFC1.PRJ). На рисунке 14 представлено окно редактора переменных
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Рисунок 13 – Решение на языке SFC
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Рисунок 14 – Окно редактора переменных
Задание 3.

Создать программу на языке SFC согласно условиям задания 1.

Возможное решение представлено на рисунке 15 (файл KRAN_SFC.PRJ). На рисунке 16 представлено окно редактора переменных.
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Рисунок 15 – Решение на языке SFC
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Рисунок 16 – Окно редактора переменных

Задание №4
«Создание программы на языке ST»
Запустите Concept. Создайте новый проект File → New project. Выполните конфигурирование контроллера. Закройте окно PLC Configuration. Для создания секции используйте команду меню File → New Section... и введите имя секции.
Имя секции (до 32 символов) должно быть уникальным для всего проекта. Имя секции должно удовлетворять соглашениям стандарта по имени иначе появится сообщение об ошибках.
Согласно стандарту только буквы допускается использовать как первый символ имени. Чтобы разрешить числа как первый символ, используйте команду меню Options → Preferences → EEC Extensions → IEC Extensions → Allow leading digits in identifiers.
При создании программы используйте команду VAR...END_VAR для объявления функциональных блоков и блоков DFB, с которы​ми вы хотите работать.
Объявите переменные и их начальные значения в редакторе переменных.
Пример логики программы:
SUM : = 0 ;
FOR I := 1 ТО 3 DO
FOR J := 1 ТО 2 DO
IF FLAG=1 THEN EXIT;
END_IF ;
SUM := SUM + J ;
 END_FOR; 
SUM := SUM +1; 
END_FOR
Команда условия выбора меню доступна, только если имеется открытая текстовая секция (IL-редактор, ST-редактор или редактор типов данных).
Используйте команду меню Edit → Expand Statement, чтобы завершить утверждение. Для ее вызова курсор мыши должен быть помещен на начальное утверждение (например, VAR, IF, CASE и т. д.).
Пример ST-программы:
Шаг 1  Введите IF.
Шаг 2 Выполните команду меню Expand statement.
 Реакция           Утверждение будет завершено с:
IF THEN
ELSEIF THEN 
ELSE 
END_IF;
Используйте команду меню Edit → Insert Text File..., чтобы открыть стандартное диалоговое окно Windows Open для загрузки файла ASCII в текстовую секцию.
Если нужно также разрешить символы строчных букв, исполь​зуйте диалоговое окно Options → Preferences → IEC Extensions... → IEC Extensions с опцией Allow case insensitive keywords.
Сохраните ST-секцию с помощью команды меню File → Save project.
Пример 4. Программирование на языке ST.

По условиям примера 1 требуется создать программу на языке ST.
Возможное решение задачи представлено ниже (файл KRAN_ST1.PRJ):

mot_le:=(on_le OR mot_le) AND NOT mot_ri AND NOT stop;

mot_ri:=(on_ri OR mot_ri) AND NOT mot_le AND NOT stop;
На рисунке 17 представлено окно редактора переменных
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Рисунок 17 – Окно редактора переменных

Задание 4. 

Создать программу на языке ST согласно условиям задания 1.

Возможное решение представлено ниже (файл KRAN_ST.PRJ):

VAR 

FBI_1_10:TON;

FBI_1_15:RS;

FBI_1_9:TON;

FBI_1_3:RS;

END_VAR

FBI_1_3(S:=on_le AND NOT mot_ri OR time_ri, R1:=stop OR time_le);

mot_le:=FBI_1_3.Q1;

FBI_1_9(IN:=FBI_1_3.Q1,PT:=t#5s);

time_le:=FBI_1_9.Q;

et_le:=TIME_TO_INT(IN:=FBI_1_9.ET);

FBI_1_15(S:=on_ri AND NOT mot_le OR time_le, R1:=stop OR time_ri);

mot_ri:=FBI_1_15.Q1;

FBI_1_10(IN:=FBI_1_15.Q1,PT:=t#10s);

time_ri:=FBI_1_10.Q;

et_ri:=TIME_TO_INT(IN:=FBI_1_10.ET);
На рисунке 18 представлено окно редактора переменных
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Рисунок 18 – Окно редактора переменных









































































































































































































































































































































































































